Ticket #8 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

gem install fails on RDOC generation

Reported by: zewerson Assigned to:
Priority: major Milestone:
Keywords: rdoc, gem Cc:

Description

when i run gem install eventmachine to install eventmachine on ruby 1.9.0-1, (osx) i get the following error:

Installing RDoc documentation for eventmachine-0.10.0...
ERROR:  While executing gem ... (NameError)
    uninitialized constant RDoc::Generator::HTML::AllReferences

installing without creating the rdocs works

gem install eventmachine --no-rdoc

but this is just a dirty solution. this should work out-of-the-box!

Change History

05/15/08 15:02:29 changed by raggi

iirc RDOC changed version under 1.9. I will try to replicate when i get a chance.

06/20/08 13:35:38 changed by raggi

  • status changed from new to closed.
  • resolution set to fixed.

Working fine on my branch under 0.12. I believe it may be working under 0.12 generally.